Summary
The user performs a search, and no search results are found.
Cause
Search results may not be returned for the following reasons:
- The search criteria do not match any files or locations in the SharePoint, Teams and OneDrive locations accessible by your account.
- The file or location may not be indexed by SharePoint. For more information, see Overview of search in SharePoint.
- The file or location you're searching for is on a different SharePoint Online tenant.
If a search is performed on email properties:
- Email properties may not be provisioned in your SharePoint site and added to document libraries.
Solution
- If the file or location exists, ensure the user has appropriate access to the location where it is stored.
- Wait until SharePoint indexes the file or location. The time it takes for an index to complete varies depending on several factors, including the number of files stored on SharePoint and its level of activity. Generally, this should be completed within an hour, though it can sometimes take up to 24 hours to be indexed.
If email properties are not configured:
- Ensure that document libraries are created using MacroView Provisioner, or using the New Document Library option in the right-click context menu when selecting a SharePoint site/Team site. For more information, see Access functions and shortcuts using the right-click context menu.