Changes in SharePoint Online have impacted the ClauseBank client's ability to obtain and refresh licenses. This issue affects ClauseBank 8.5.05 and all earlier versions. On premises SharePoint servers are unaffected.
Symptoms
Unknown Licence Status
When adding or editing a SharePoint Online server the Licence Status displays 'Unknown' even though the tenant is properly activated.
Unable to Insert Clauses
The following message is displayed when attempting to insert clauses:
Cause
A SharePoint web service relied on by ClauseBank has been deprecated and is returning an unexpected response.
This issue can occur in the following scenarios:
- When the ClauseBank client software is upgraded.
- When a new SharePoint Online server is added.
- When an existing license expires.
- When ClauseBank is installed on a new PC or in a new user profile.
Resolution
Update your ClauseBank Client software to resolve this issue. You can obtain the latest version from the ClauseBank download page.